re = /Volume{(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)}/m
str = 'Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}
\\\\\\\\?\\\\Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}\\\\
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end