// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Volume{(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)}").unwrap();
let string = "Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}
\\\\\\\\?\\\\Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}\\\\
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}