#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=TO_DATE\().{12}"
Local $sString = "TO_DATE('2020-04-25', 'yyyy-mm-dd')" & @CRLF & _
"TO_DATE('2020-04-03', 'yyyy-mm-dd')" & @CRLF & _
"TO_DATE('2020-03-23', 'yyyy-mm-dd')" & @CRLF & _
"TO_DATE('2020-03-11', 'yyyy-mm-dd')" & @CRLF & _
"TO_DATE('2020-04-21', 'yyyy-mm-dd')" & @CRLF & _
"TO_DATE('2020-02-24', 'yyyy-mm-dd')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")