import Foundation
let pattern = #"(?<=TO_DATE\().{12}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TO_DATE('2020-04-25', 'yyyy-mm-dd')
TO_DATE('2020-04-03', 'yyyy-mm-dd')
TO_DATE('2020-03-23', 'yyyy-mm-dd')
TO_DATE('2020-03-11', 'yyyy-mm-dd')
TO_DATE('2020-04-21', 'yyyy-mm-dd')
TO_DATE('2020-02-24', 'yyyy-mm-dd')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)