const regex = /(?<=TO_DATE\().{12}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=TO_DATE\\().{12}', 'gm')
const str = `TO_DATE('2020-04-25', 'yyyy-mm-dd')
TO_DATE('2020-04-03', 'yyyy-mm-dd')
TO_DATE('2020-03-23', 'yyyy-mm-dd')
TO_DATE('2020-03-11', 'yyyy-mm-dd')
TO_DATE('2020-04-21', 'yyyy-mm-dd')
TO_DATE('2020-02-24', 'yyyy-mm-dd')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}