#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\).*?\(|^.*?\(|\).*?$"
Local $sString = "SOME TEXT (BI1) SOME MORE TEXT (BI17) SOME FINAL TEXT (BI1234)";"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)