const regex = /\).*?\(|^.*?\(|\).*?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\).*?\\(|^.*?\\(|\\).*?$', 'g')
const str = `SOME TEXT (BI1) SOME MORE TEXT (BI17) SOME FINAL TEXT (BI1234)";`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);