using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\).*?\(|^.*?\(|\).*?$";
string substitution = @" ";
string input = @"SOME TEXT (BI1) SOME MORE TEXT (BI17) SOME FINAL TEXT (BI1234)"";";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}