using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<=\#).*$\b";
string input = @"Can we talk about tags?
What is better, single or multi-word tags? I submit to you, multi-word tags are superior. I wrote this regular expression to demonstrate an implementation of multi-word tags in Obsidian.
#feature request
#obsidian app
#multi-word tags
#zettelkasten method
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}