$re = '/\b(?<=\#).*$\b/m';
$str = 'Can we talk about tags?
What is better, single or multi-word tags? I submit to you, multi-word tags are superior. I wrote this regular expression to demonstrate an implementation of multi-word tags in Obsidian.
#feature request
#obsidian app
#multi-word tags
#zettelkasten method
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);