import Foundation
let pattern = ##"\b(?<=\#).*$\b"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Can we talk about tags?
What is better, single or multi-word tags? I submit to you, multi-word tags are superior. I wrote this regular expression to demonstrate an implementation of multi-word tags in Obsidian.
#feature request
#obsidian app
#multi-word tags
#zettelkasten method
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)