use strict;
my $str = 'Can we talk about tags?
What is better, single or multi-word tags? I submit to you, multi-word tags are superior. I wrote this regular expression to demonstrate an implementation of multi-word tags in Obsidian.
#feature request
#obsidian app
#multi-word tags
#zettelkasten method
';
my $regex = qr/\b(?<=\#).*$\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}