#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[-_].*|.*[-_])$"
Local $sString = "// pass" & @CRLF & _
"" & @CRLF & _
"sdq" & @CRLF & _
"lorem ipsum" & @CRLF & _
"abc_def" & @CRLF & _
"harry-_potter" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// catch" & @CRLF & _
"fg_" & @CRLF & _
"_asq" & @CRLF & _
"_dqw-" & @CRLF & _
"-asq-sq"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")