package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[-_].*|.*[-_])$`)
var str = `// pass
sdq
lorem ipsum
abc_def
harry-_potter
// catch
fg_
_asq
_dqw-
-asq-sq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}