re = /^(?:[-_].*|.*[-_])$/m
str = '// pass
sdq
lorem ipsum
abc_def
harry-_potter
// catch
fg_
_asq
_dqw-
-asq-sq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end