import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[-_].*|.*[-_])$";
final String string = "// pass\n\n"
+ "sdq\n"
+ "lorem ipsum\n"
+ "abc_def\n"
+ "harry-_potter\n\n\n"
+ "// catch\n"
+ "fg_\n"
+ "_asq\n"
+ "_dqw-\n"
+ "-asq-sq";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}