#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?(?<=\d{4})-?|)(\d)(?!\2{3}|\2{2}-\2|\2-\2{2}|-\2{3})){16}\b"
Local $sString = "5123-4567-8912-3456" & @CRLF & _
"6123456789123456" & @CRLF & _
"4123356789123456" & @CRLF & _
"5133336789123456" & @CRLF & _
"1234567890134443" & @CRLF & _
"123-4567-8901-23456" & @CRLF & _
"1234-4567890123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")