$re = '/\b((?(?<=\d{4})-?|)(\d)(?!\2{3}|\2{2}-\2|\2-\2{2}|-\2{3})){16}\b/';
$str = '5123-4567-8912-3456
6123456789123456
4123356789123456
5133336789123456
1234567890134443
123-4567-8901-23456
1234-4567890123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);