import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?(?<=\\d{4})-?|)(\\d)(?!\\2{3}|\\2{2}-\\2|\\2-\\2{2}|-\\2{3})){16}\\b";
final String string = "5123-4567-8912-3456\n"
+ "6123456789123456\n"
+ "4123356789123456\n"
+ "5133336789123456\n"
+ "1234567890134443\n"
+ "123-4567-8901-23456\n"
+ "1234-4567890123456";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}