const regex = /\b((?(?<=\d{4})-?|)(\d)(?!\2{3}|\2{2}-\2|\2-\2{2}|-\2{3})){16}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?(?<=\\d{4})-?|)(\\d)(?!\\2{3}|\\2{2}-\\2|\\2-\\2{2}|-\\2{3})){16}\\b', 'g')
const str = `5123-4567-8912-3456
6123456789123456
4123356789123456
5133336789123456
1234567890134443
123-4567-8901-23456
1234-4567890123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}