# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Example(\d+)|./$1 /gm;t' <<< "Example1 another text 123 Example500 text"