use strict;
my $str = 'Example1 another text 123 Example500 text';
my $regex = qr/Example(\d+)|./mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";