using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Example(\d+)|.";
string substitution = @"$1 ";
string input = @"Example1 another text 123 Example500 text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}