package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?[0-9]{0,3}-?[0-9]{7,10}$`)
var str = `happy cases:
+919876576543
+91-9876576543
91-9876576543
919876576543
9876576543
sad cases:
+91 9773938389
91 9773938389
97739 75647
(+91)-9876576543
(+91)9876576543
(91)9876576543`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}