import Foundation
let pattern = #"^\+?[0-9]{0,3}-?[0-9]{7,10}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
happy cases:
+919876576543
+91-9876576543
91-9876576543
919876576543
9876576543
sad cases:
+91 9773938389
91 9773938389
97739 75647
(+91)-9876576543
(+91)9876576543
(91)9876576543
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)