const regex = new RegExp('^[a-f\\d]+(?:-{1,2}>[a-f\\d]+)+$', 'gm')
const str = `0912adbd->12d1829-->218990d
ab2c8d-->82a921->193acd7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}