$re = '/^[a-f\d]+(?:-{1,2}>[a-f\d]+)+$/m';
$str = '0912adbd->12d1829-->218990d
ab2c8d-->82a921->193acd7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);