// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-f\d]+(?:-{1,2}>[a-f\d]+)+$").unwrap();
let string = "0912adbd->12d1829-->218990d
ab2c8d-->82a921->193acd7";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}