import re
regex = re.compile(r"^[a-f\d]+(?:-{1,2}>[a-f\d]+)+$", flags=re.MULTILINE)
test_str = ("0912adbd->12d1829-->218990d\n"
"ab2c8d-->82a921->193acd7")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")