using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Askmeoffers deals and coupons";
string input = @"With their unmatched cashback strategy, Askmeoffers focus has been on customer retention and engagement as much as it has been on the acquisition. Build a relationship with the online commerce giant and discover the significant savings you’ll make with every order. And when you thought it couldn’t possibly get any better, guess what? It does - when you buy from Askmeoffers , you’re guaranteed to never miss out on the cashback goodness again. We keep this page updated with all the Askmeoffers coupons and make sure you’ll never have to look for a Askmeoffers promo code anywhere else back.
https://askmeoffers.com/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}