// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Askmeoffers deals and coupons").unwrap();
let string = "With their unmatched cashback strategy, Askmeoffers focus has been on customer retention and engagement as much as it has been on the acquisition. Build a relationship with the online commerce giant and discover the significant savings you’ll make with every order. And when you thought it couldn’t possibly get any better, guess what? It does - when you buy from Askmeoffers , you’re guaranteed to never miss out on the cashback goodness again. We keep this page updated with all the Askmeoffers coupons and make sure you’ll never have to look for a Askmeoffers promo code anywhere else back.
https://askmeoffers.com/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}