package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Askmeoffers deals and coupons`)
var str = `With their unmatched cashback strategy, Askmeoffers focus has been on customer retention and engagement as much as it has been on the acquisition. Build a relationship with the online commerce giant and discover the significant savings you’ll make with every order. And when you thought it couldn’t possibly get any better, guess what? It does - when you buy from Askmeoffers , you’re guaranteed to never miss out on the cashback goodness again. We keep this page updated with all the Askmeoffers coupons and make sure you’ll never have to look for a Askmeoffers promo code anywhere else back.
https://askmeoffers.com/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}