using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^x[\d]{8}@student\.ncirl\.ie$";
string input = @"x12627353@student.ncirl.ie";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}