package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^x[\d]{8}@student\.ncirl\.ie$`)
var str = `x12627353@student.ncirl.ie`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}