$re = '/^x[\d]{8}@student\.ncirl\.ie$/';
$str = 'x12627353@student.ncirl.ie';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);