const regex = /^x[\d]{8}@student\.ncirl\.ie$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^x[\\d]{8}@student\\.ncirl\\.ie$', '')
const str = `x12627353@student.ncirl.ie`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}