using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/etc/(xx|yy)/(abc|xyz)/(.*?)(?://.*)?$";
string input = @"/etc/xx/abc/path/to/controller//myDesiredMVCAction
and not:
/etc/xx/abc/path/to/controller";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}