re = /^\/etc\/(xx|yy)\/(abc|xyz)\/(.*?)(?:\/\/.*)?$/m
str = '/etc/xx/abc/path/to/controller//myDesiredMVCAction
and not:
/etc/xx/abc/path/to/controller'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end