$re = '~^/etc/(xx|yy)/(abc|xyz)/(.*?)(?://.*)?$~m';
$str = '/etc/xx/abc/path/to/controller//myDesiredMVCAction
and not:
/etc/xx/abc/path/to/controller';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);