package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/etc/(xx|yy)/(abc|xyz)/(.*?)(?://.*)?$`)
var str = `/etc/xx/abc/path/to/controller//myDesiredMVCAction
and not:
/etc/xx/abc/path/to/controller`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}