#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)TicketNumber=(\d+)"
Local $sString = "https://test.ru/index.php?Action=Get;TicketNumber=53861#414922" & @CRLF & _
"https://test.ru/index.php?Action=Get;TicketNumber=53861;TicketQueue=Support#414922" & @CRLF & _
"https://test.ru/index.php?Action=Get;TicketNumber=53861"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")