package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TicketNumber=(\d+)`)
var str = `https://test.ru/index.php?Action=Get;TicketNumber=53861#414922
https://test.ru/index.php?Action=Get;TicketNumber=53861;TicketQueue=Support#414922
https://test.ru/index.php?Action=Get;TicketNumber=53861`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}