import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TicketNumber=(\\d+)";
final String string = "https://test.ru/index.php?Action=Get;TicketNumber=53861#414922\n"
+ "https://test.ru/index.php?Action=Get;TicketNumber=53861;TicketQueue=Support#414922\n"
+ "https://test.ru/index.php?Action=Get;TicketNumber=53861";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}