re = /TicketNumber=(\d+)/m
str = 'https://test.ru/index.php?Action=Get;TicketNumber=53861#414922
https://test.ru/index.php?Action=Get;TicketNumber=53861;TicketQueue=Support#414922
https://test.ru/index.php?Action=Get;TicketNumber=53861'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end