using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/]*)";
        string substitution = @"";
        string input = @"http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile";
        RegexOptions options = RegexOptions.Multiline;
        
        Regex regex = new Regex(pattern, options);
        string result = regex.Replace(input, substitution);
    }
}