import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http?:\\/\\/|https?:\\/\\/)?(?:www\\.)?stackoverflow\\.com\\/(?:\\/*)([\\w\\-\\.\\/]*)";
final String string = "http://stackoverflow.com/cv/razvan-ciocanel\n"
+ "http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}