const regex = /(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http?:\\\/\\\/|https?:\\\/\\\/)?(?:www\\.)?stackoverflow\\.com\\\/(?:\\\/*)([\\w\\-\\.\\\/]*)', 'gm')
const str = `http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);