using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""|^["" . preg_quote('a-zA-Z 0-9~%.:;*_') . ""]+$|i""
";
string input = @"www.seligsealing.com/css.php/selig/cssautoloadorder/default:lytebox:jNice:toptabform";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}