const regex = /"|^[" . preg_quote('a-zA-Z 0-9~%.:;*_') . "]+$|i"
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"|^[" . preg_quote(\'a-zA-Z 0-9~%.:;*_\') . "]+$|i"
', '')
const str = `www.seligsealing.com/css.php/selig/cssautoloadorder/default:lytebox:jNice:toptabform`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}