package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"|^[" . preg_quote('a-zA-Z 0-9~%.:;*_') . "]+$|i"
`)
var str = `www.seligsealing.com/css.php/selig/cssautoloadorder/default:lytebox:jNice:toptabform`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}